GNOME-2.16 in unstable

Yes. That’s right.
GNOME-2.16 is out of package.mask and now nearing your unstable ~arch systems closest mirror with the speed of, :-/, electrons.
This is currently a 2.16.1 version of it.
For the rare (sub)profiles using Linux kernel version 2.4, GNOME-2.16 will stay masked, due to it requiring HAL (Hardware Abstraction Layer) quite heavily. The Linux version of it uses udev, which is new in 2.6 kernel. These profiles will however now get gtk+-2.10 with the necessary dependencies in their ~arch.

There is an upgrading guide over here:
http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.16-upgrade.xml

It is likely that it will gain more items to it over time as things come up.

Enjoy! I know I am.
For the stable machines, well, the clock is ticking now.

Thanks to the GNOME desktop team for pulling this through!
I just got to do the finishing touches B)

Oh and I received a Gentoo GNOME team member badge some time ago for some reason :>>

5 thoughts on “GNOME-2.16 in unstable”

  1. Hopefully this will also disappear from package.mask since gnome-2.16 is on it’s way to stable.

    # Patrick McLean <chutzpah@gentoo.org> (25 Sep 2006)
    # This depends on dev-cpp/cairomm which is in the Gnome 2.16 mask, so masking
    # until Gnome 2.16 is unmasked
    =media-sound/bmpx-0.3*

  2. C++, mono and java bindings were not unmasked on purpose just yet. The respective herd teams for these will have to take care of this – see http://bugs.gentoo.org/show_bug.cgi?id=132627
    There are some things to sort out wrt some subprofiles having GNOME-2.16 masked due to 2.4 kernel, so they’ll need to figure out which need to be masked and which not (e.g, gtk bindings should be possible to unmask, while a vte bindings that requires the newer vte can’t be) in these profiles.

Leave a Reply

Your email address will not be published. Required fields are marked *